Автор Тема: Проблеми  (Прочетена 13529 пъти)

galants

  • Робо-Новак
  • *****
  • Публикации: 30
    • Профил
Проблеми
« -: Август 11, 2007, 08:54:50 pm »
Тъй като аз имам проблем с направата на робота си, си помислих, че ще е хубаво да има място където да дискутираме проблемите а не да ги пишем из другите теми.
След дълги безуспешни опити да раздвижа робота си, реших да потърся помощ от по-напредналите  :D
Това е моя робот!








Моля кажете къде бъркам!!!! :!:  :x
В. Николов, гр. София, 27 г.

Borislav

  • Administrator
  • *****
  • Публикации: 1010
    • Профил
    • http://robotics-bg.com
Проблеми
« Отговор #1 -: Август 11, 2007, 09:46:03 pm »
Свързването на елементите е правилно. Виж дали свръзките на кабелчетата със куплунга на L293D са добре запоени... И като цяло, фототранзисторът ти самоделка ли е? И кабелите ми изглеждат много дебели...
Роботиката не е хоби - тя е начин на живот!

galants

  • Робо-Новак
  • *****
  • Публикации: 30
    • Профил
Проблеми
« Отговор #2 -: Август 11, 2007, 10:00:53 pm »
Фототранзисторът е BPW77NB. Проводниците са едно жилни високо честотни, просто са малко дебели. ;)
Добре, проблема къде може да е?
В. Николов, гр. София, 27 г.

spp

  • Global Moderator
  • *****
  • Публикации: 414
    • Профил
    • http://robotics.cnc-bg.net/
Проблеми
« Отговор #3 -: Август 11, 2007, 10:30:29 pm »
Добре ,да тестваме нещата едно по едно.Направи следното.Не слагай интегралната схема в куплунга.Подай захранващо напрежение и с уред замери какъв е спада върху фототранзистора.За целта крачето му,което е към схената го свържи с едно кабелче с минуса.Схемата я има в буквара-опит.Ако напрежението е малко.Почти нулево е добре.После затъмни фототранзистора и отново го измери.Трябва да е високо .Много по-високо отколкото върху резитора.Ако е така означава ,че фототранзистора работи.
Тази схема,която правите не е хубава.Много неща не са направени по нея и нищо чудно,че не върви.Ще тесвам утре драйвера,ако ми остане време.Ако не в понеделник и ще поправим схемата ,за да върви,като хората.
Но за момента можеш да направиш тази проверка,която ти описах.
Слави Петков
София 49г

Borislav

  • Administrator
  • *****
  • Публикации: 1010
    • Профил
    • http://robotics-bg.com
Проблеми
« Отговор #4 -: Август 11, 2007, 11:27:48 pm »
Цитат на: "spp"
Тази схема,която правите не е хубава.Много неща не са направени по нея и нищо чудно,че не върви.Ще тесвам утре драйвера,ако ми остане време.Ако не в понеделник и ще поправим схемата ,за да върви,като хората.


По принцип при мен върви без проблем робота. :) Като цяло може да осъвършенстваме конструкцията - би било много добре! Честно казано, не съм се замислял, че може да дава дефект.. Като цяло си помислих за съпротивлението на проводниците...
Роботиката не е хоби - тя е начин на живот!

galants

  • Робо-Новак
  • *****
  • Публикации: 30
    • Профил
Проблеми
« Отговор #5 -: Август 12, 2007, 12:45:02 pm »
Измерих фототранзистора, падовете са наред.
Сега замених транзистора с фото диод и пак нищо.! :?:
В. Николов, гр. София, 27 г.

Borislav

  • Administrator
  • *****
  • Публикации: 1010
    • Профил
    • http://robotics-bg.com
Проблеми
« Отговор #6 -: Август 12, 2007, 03:42:07 pm »
Като цяло тия проводници не ми вдъхват доверие... Можеш ли да ги замениш с едножилни - по-тънки?
Роботиката не е хоби - тя е начин на живот!

galants

  • Робо-Новак
  • *****
  • Публикации: 30
    • Профил
Проблеми
« Отговор #7 -: Октомври 17, 2007, 10:34:28 pm »
В схемата по горе проблемът е, че съм подал захранване на двата енеибала и на единия Vcc  ;(  сега работи :) Вместо фототранзистор ползвам транзистор с фоторезистор между базата и колектора така мога по лесно да управлявам чуствителноста на датчика.  :clap:  :twisted:  :idea:
Ако някои има проблем с драйвера може да пише ЛС, ще му помогна :D
P.S. Проводниците са си наред!
В. Николов, гр. София, 27 г.

  • Гост
Проблеми
« Отговор #8 -: Октомври 18, 2007, 06:14:23 pm »
тези проводници по принцип не са хубави:дебели са,едножилни и бърти ползват се по старите телефонни централи,имам същите но ги изхвърлих след като установих че са корозирали отвътре.Виждам че схемата работи с тях може ида не ги сменяш,но както те посъветва Борислав може да ги замениш с по добри :clap:

galants

  • Робо-Новак
  • *****
  • Публикации: 30
    • Профил
Проблеми
« Отговор #9 -: Октомври 18, 2007, 08:25:31 pm »
Да така е, наистина са от телефони централи, но в момента също се ползват и не са остариали  :D  Хубавото на тези проводници е, че могат да провеждат сигнал с висока честота, иначе за такива схеми наистина не са подходящи, тъй като са много жилави :evil:  , но поради липса на други  :)  и тези стават.
В. Николов, гр. София, 27 г.