Автор Тема: RF 434 MHz - проблем  (Прочетена 7976 пъти)

Tsoni

  • Вече знае какво е робот!
  • *****
  • Публикации: 88
    • Профил
RF 434 MHz - проблем
« -: Ноември 15, 2014, 10:54:42 pm »
Проблемът е със следните устройства: http://www.ebay.com/itm/1x-Receptor-Emisor-inalambrico-RF-Arduino-433Mhz-ARDUINO-WIRELES-RF-MODULE-/141411917836?pt=LH_DefaultDomain_186&hash=item20eccea00c
Пробвах кодове и схеми за свързване от всевъзможни източници, еми не става.Пробвах и с различни чифтове предавател/приемник, пак не ще...Кодовете иначе работят на модулите от роботев, които са на същата честота, но ми трябват тези да бачкат.
Та ако някой има такива, или поне знае за какво иде реч, моля да предложи схема за свързване и съвсем прост код, само за проба дали работят.
Цони Витков 17 г. МГ \"Гео Милев\" Плевен

tonko_lonko

  • Робо-Новак
  • *****
  • Публикации: 18
    • Профил
Re: RF 434 MHz - проблем
« Отговор #1 -: Ноември 18, 2014, 10:51:50 am »
тия модули са много мизерни.
Свързват се елементарно -vcc,gnd и дата пин-а.Малкото е предавателя, а приемника е по-голямото.Ползваш VirtualWire lib-a и свързваш към пин 11 и 13 май бяха-но провери. Гледай да качиш кода на предавателя на ардуиното с малката джаджа че аз веднъж ги бях разменил и загубих адски много време докато се усетя че качвам код за предавател на приемника и обратно-адски тъпо.
Освен това ако искаш обхват повече от 10см свържи медна жица 17.3см и към двата модула.
Ако ти трябва по-голям обхват предавателя се пържи до 12В.
Успех.

tonko_lonko

  • Робо-Новак
  • *****
  • Публикации: 18
    • Профил
Re: RF 434 MHz - проблем
« Отговор #2 -: Ноември 18, 2014, 10:54:00 am »
Забравих да кажа че VirtualWire не работи с Servo lib заради таймерите. Така че ако проекта ти има Нещо общо с серво -полззвай ServoTimer2 или SoftwareServo или RCSwitch